Задать вопрос
17 июня, 05:34

Задание #1

Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.

Задание #2

Напиши программу, вычисляющую стоимость покупки с учетом 10 %-й скидки, которая предоставляется только в том случае, если сумма покупки больше 1000 рублей.

Задание #3

Напиши программу, вычисляющую сумму всех четных чисел от 1 до N.

Задание #4

Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

+1
Ответы (1)
  1. 17 июня, 06:09
    0
    Написал по-быстрому

    1) var a, b, s, p:real;

    begin

    readln (a) ;

    readln (b) ;

    s:=a*b;

    p: = (a+b) / 2;

    writeln ('s: = ', s) ;

    writeln ('p: = ', p) ;

    end.

    2) var s:real;

    begin

    readln (s) ;

    if (s>=1000) then s:=s - (s*0.1)

    writeln (s) ;

    end.

    3) var i, a, n:integer;

    s:real;

    begin

    s:=0;

    readln (n) ;

    for i:=1 to n do readln (a) ;

    if (a mod 2=0) then s:=s+a;

    writeln (s) ;

    end.

    4) const n = 10;

    var a:array[1 ... n] of integer;

    i:integer;

    s:real;

    begin

    s:=0;

    for i:=1 to n do

    begin

    readln (a[i]) ;

    s:=s + (a[i]) ;

    end;

    writeln (s/n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. (Pascal)
Ответы (1)