Задать вопрос
15 декабря, 10:35

Составить программу которая поставит максимальный элемент массива на первое место (массив из 10 целых случайных чисел)

+3
Ответы (1)
  1. 15 декабря, 11:00
    0
    Var

    i, max, m:integer;

    a:array[1 ... 10]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    write (a[i],' ') ;

    if a[i]>max then

    begin

    max:=a[i];

    m:=i;

    end;

    end;

    writeln;

    writeln ('Измененный массив:') ;

    i:=a[1];

    a[1]:=a[m];

    a[m]:=i;

    for i:=1 to 10 do write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая поставит максимальный элемент массива на первое место (массив из 10 целых случайных чисел) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы