Задать вопрос
16 июня, 08:31

Написать программу о нахождении двухзначного числа А. Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами

+2
Ответы (1)
  1. 16 июня, 09:46
    0
    Var a, a1, a2:integer;

    begin

    readln (a) ;

    a1:=a div 10;

    a2:=a mod 10;

    writeln ("Сумма цифр = ", a1+a2) ;

    writeln ("Произведение цифр = ", a1*a2) ;

    writeln ("Число наоборот: ", a2*10+a1) ;

    end.

    Пример:

    25

    Сумма цифр = 7

    Произведение цифр = 10

    Число наоборот: 52
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу о нахождении двухзначного числа А. Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы