Задать вопрос
20 февраля, 05:20

Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (Паскаль)

+2
Ответы (1)
  1. 20 февраля, 08:02
    0
    Var mas30: array [1 ... 30] of integer;

    var i, proz: integer;

    begin

    proz:=1;

    for i:=1 to 30 do begin mas30[i]:=-5+random (11) ; / / Заполнение массива

    write (mas30[i], ' ') ; / / вывод значений массива

    end;

    writeln;

    for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; / / Подсчет произведения отриц элементов

    writeln (proz) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы