Задать вопрос
4 апреля, 19:00

Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! + 3! + ... + n! (n>=1) Решить через repeat (с постусловием)

+4
Ответы (1)
  1. 4 апреля, 20:23
    0
    Var S, f:longint; n, a:byte;

    begin

    s:=0; a:=1; f:=1;

    readln (n) ;

    repeat

    f:=f*a;

    s:=s+f;

    inc (a) ;

    until a>n;

    writeln (s) ;

    end.

    Вроде так
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! + 3! + ... + n! (n>=1) Решить через repeat (с постусловием) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы