Задать вопрос
15 декабря, 23:08

напишите программу для паскаля.

условие: обменять значения двух переменных, используя третью (буферную) переменную

+1
Ответы (1)
  1. 16 декабря, 01:15
    0
    var

    a, b, buf:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    buf : = a;

    a : = b;

    b : = buf;

    writeln ('a = ', a) ;

    writeln ('b = ', b) ;

    end.

    / / без буферной переменной

    var

    a, b:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    a : = a + b;

    b : = a - b;

    a : = a - b;

    writeln ('a = ', a) ;

    writeln ('b = ', b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «напишите программу для паскаля. условие: обменять значения двух переменных, используя третью (буферную) переменную ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы