Задать вопрос
12 марта, 04:35

Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.

+2
Ответы (1)
  1. 12 марта, 08:12
    0
    Program rabota_01;

    var m, n: Longint;

    i, j: Integer;

    begin

    Write ('Введите M: ') ; ReadLn (m) ;

    for i:=Trunc (Sqrt (m)) downto 1 do begin

    n:=Sqr (i) ; j:=1; while (j<=i) and (n+Sqr (j)
    if n+Sqr (j) = m then begin

    WriteLn (m,' = ', i,'^2 + ', j,'^2') ; Exit;

    end;

    end;

    WriteLn (m,' не является суммой квадратов натуральных чисел.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы