Задать вопрос
6 декабря, 21:29

Написать программу в Паскале

Ввести натуральное число N и вычислить сумму всех чисел Фибоначчи, меньших N. Предусмотрите защиту от ввода отрицательного числа N. Пример: Введите число N: 10000 Сумма 17709

+1
Ответы (1)
  1. 6 декабря, 23:11
    0
    Var n, f1, f2, fn, sum:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    while n<=0 do

    begin

    writeln ('Введите n>0. n = ') ;

    readln (n) ;

    end;

    f1:=1; f2:=1;

    fn:=f1+f2;

    while fn
    begin

    sum:=sum+fn;

    fn:=f1+f2;

    f1:=f2;

    f2:=fn;

    end;

    writeln ('sum=', sum) ;

    end.

    Пример:

    n = - 10

    Введите n>0. n = 10000

    sum=17710
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале Ввести натуральное число N и вычислить сумму всех чисел Фибоначчи, меньших N. Предусмотрите защиту от ввода ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы