Задать вопрос
6 мая, 19:17

Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, удовлетворяющие условию А (i) <=5.5, переписать в массив С. В массиве А m элементов.

+3
Ответы (1)
  1. 6 мая, 21:28
    0
    var

    A, B, C: array[1 ... 100] of integer;

    i, n, j, k:integer;

    begin

    randomize;

    j:=0;

    k:=0;

    Readln (n) ;

    Writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    A[i]:=random (10) ;

    writeln ('A[', i,']=', A[i]) ;

    end;

    for i:=1 to n do

    if A[i]>5.5

    then

    begin

    j:=j+1;

    B[j]:=A[i];

    end;

    for i:=1 to n do

    if A[i]<=5.5

    then

    begin

    K:=k+1;

    C[k]:=A[i];

    end;

    for i:=1 to j do

    writeln ('B[', i,']=', B[i]) ;

    for i:=1 to k do

    writeln ('C[', i,']=', C[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы