Задать вопрос
7 июля, 19:47

Помогите!

Напишите программу, которая в последовательности натуральных чисел определяет количество трехзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введенных чисел, неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: количество трехзначных чисел, кратных 4.

(Паскаль)

+1
Ответы (1)
  1. 7 июля, 23:44
    0
    Var A, k:integer;

    Begin

    k:=0;

    Repeat

    Read (A) ;

    if (A>99) and (A<1000) and (A mod 4 = 0) then k:=k+1

    Until A = 0;

    WriteLn (k) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! Напишите программу, которая в последовательности натуральных чисел определяет количество трехзначных чисел, кратных 4. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы