Задать вопрос
9 мая, 01:07

Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. Если в числе нет цифры 7, то следует вывести число в исходном виде (через оператор if) Паскаль

+1
Ответы (1)
  1. 9 мая, 04:28
    0
    Var a:integer; s:string;

    begin

    readln (a) ;

    str (a, s) ;

    if (pos ('7', s) >0)

    then

    a:=a*a;

    writeln (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. Если ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы