Задать вопрос
18 мая, 19:17

Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 69?

var n, s, d: integer;

begin

readln (d) ;

n : = 14;

s : = 29;

while s < = 2000 do begin

s : = s + d;

n : = n + 5

end;

write (n)

end.

+3
Ответы (1)
  1. 18 мая, 19:25
    0
    Можно ввести 18 значений от 180 до 197.

    Из программы видно, что 14+k*5 = 69 = > k = 11

    29 + k*d > = 2000, отсюда получаем минимальное значение d

    d = 1971/11 = 179,18, но так как d - целое, то d min = 180.

    Максимальное значение d из условия: d max = (1999-29) / 10 = 197
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 69? var n, s, d: integer; begin readln ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы