Задать вопрос
27 августа, 03:19

Написать программу ввода целых чисел с клавиатуры, пока не будет введён 0

+4
Ответы (1)
  1. 27 августа, 04:06
    0
    {с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min и max, чтобы потом в цикле было с чем сравнивать}

    var

    min, max, a:real;

    begin

    readln (a) ;

    min:=a; max:=a;

    while a0 do

    begin

    readln (a) ;

    if a>max then

    max:=a;

    if a
    min:=a;

    end;

    writeln ('min: ', min,' max: ', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу ввода целых чисел с клавиатуры, пока не будет введён 0 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы