Задать вопрос
20 ноября, 07:11

Составьте программу вычисления площади кольца с внутренним радиусом R1 и внешним радиусом R2. Значения R1 и R2 введите с клавиатуры

+4
Ответы (1)
  1. 20 ноября, 09:13
    0
    Если твое кольцо есть фигура Тор, то это внешний и внутренний радиусы. (Внешний больше). Тогда код вот такой:

    uses crt;

    var

    r1, r2: real;

    begin

    read (r1, r2) ;

    writeln (pi * (r1*r1-r2*r2) : 0:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу вычисления площади кольца с внутренним радиусом R1 и внешним радиусом R2. Значения R1 и R2 введите с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы