Задать вопрос
30 ноября, 02:24

Помогите написать программу на Паскале

1. написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из двух чисел единиц больше.

+1
Ответы (1)
  1. 30 ноября, 04:53
    0
    Var

    s, s2: string;

    function one (s: string) : integer;

    var i, c: integer;

    begin

    c : = 0;

    for i : = 1 to length (s) do

    if (s[i] = '1') then c : = c + 1;

    result : = c;

    end;

    begin

    writeln ('Введите первое число:') ;

    readln (s) ;

    writeln ('Введите второе число:') ;

    readln (s2) ;

    if (one (s) > one (s2)) then write ('В первом числе больше единиц')

    else write ('Во втором числе больше единиц') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на Паскале 1. написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы