Задать вопрос
10 апреля, 03:46

Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел (Определенного типа) к переполнению.

+1
Ответы (1)
  1. 10 апреля, 06:14
    0
    Const

    low=-32768;

    high=32767;

    Var i, j : integer;

    begin

    readln (i, j) ;

    if sign (i) * sign (j) <0 then writeln ('Сложение допустимо, результат ', i+j)

    else

    if i<0 then

    if j
    else writeln ('Сложение допустимо, результат ', i+j)

    else

    if j>high-i then writeln ('Сложение недопустимо: возникнет переполнение')

    else writeln ('Сложение допустимо, результат ', i+j)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел (Определенного типа) к переполнению. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы