Задать вопрос
4 января, 10:21

Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество элементов кратных 3.

+3
Ответы (1)
  1. 4 января, 11:42
    0
    Var

    a:array [1 ... 30] of integer; / / тут можешь регулировать количество чисел

    i, k, n:integer;

    begin

    k:=0;

    writeln ('введите количество чисел от 1 до 30') ;

    read (n) ;

    randomize;

    for i:=1 to n do begin

    a[i]:=random (16) - 5;

    write (a[i]:3) ;

    end;

    writeln () ;

    for i:=1 to n do if (a[i] mod 3=0) and (a[i]0) then k:=k+1;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы