Задать вопрос
2 марта, 06:34

Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

- квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

-точка с координатами (x, y) принадлежит части плоскости, лежащей между прямыми x=m, x=n (m

+1
Ответы (1)
  1. 2 марта, 08:40
    0
    var b: 100 ... 999;

    s: word;

    x, y, m, n: integer;

    begin

    writeln ('Введите трехзначное число') ;

    readln (b) ;

    s: = (b mod 10) + ((b mod 100) div 10) + (b div 100) ; / / сумма цифр трехзначного числа

    if sqr (b) = sqr (s) * s then writeln ('True')

    else writeln ('False') ;

    writeln ('Введите координаты х и у') ;

    readln (x, y) ;

    writeln ('Введите m и n') ;

    readln (m, n) ;

    if (x>m) and (x
    else writeln ('False') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия: - квадрат заданного ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы