Задать вопрос
18 июня, 14:40

Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления произведения элементов массива, которые не четны и делятся на 3.

+4
Ответы (1)
  1. 18 июня, 17:54
    0
    const n=10;

    var

    a:array [1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (100) ;

    write (a[i],' ') ;

    end;

    for i:=1 to n do if (a[i] mod 2 = 1) and (a[i] mod 3 = 0) then if s=0 then s:=a[i] else s:=s*a[i];

    writeln;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы