Задать вопрос
10 февраля, 19:38

Составить

программу, которая подсчитывает общее количество целых пятизначных чисел, составленных

из различных цифр, которые обладают тем свойством, что число, образованное

первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число,

образованное последними двумя цифрами.

Например, число: 12896: 12*8=96, значит число подходит.

+3
Ответы (1)
  1. 10 февраля, 22:16
    0
    Var

    i, n, a, b, c: longint;

    begin

    n : = 0;

    for i : = 10000 to 99999 do

    begin

    a : = i div 1000;

    b : = (i div 100) mod 10;

    c : = i mod 100;

    if a * b = c then n : = n + 1

    end;

    Writeln ('Найдено чисел: ', n)

    end.

    Результат работы программы:

    Найдено чисел: 286
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые обладают тем ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы