Задать вопрос
14 июля, 15:02

Цикл с параметром. Pascale. Нужно написать программу.

Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в диапозоне от - 50 до 50.

+1
Ответы (1)
  1. 14 июля, 16:28
    0
    Const nmax = 30;

    var a:array [1 ... nmax] of integer;

    i, k, n:integer;

    begin

    randomize;

    k:=0;

    repeat

    write ('N = ') ;

    readln (n) ;

    until n in [1 ... nmax];

    for i:=1 to n do

    begin

    a[i]:=random (101) - 50;

    writeln (a[i]) ;

    if a[i] mod 5 = 0 then inc (k) ;

    end;

    writeln ('Kol-vo: ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Цикл с параметром. Pascale. Нужно написать программу. Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы