Задать вопрос
30 июня, 19:16

Язык Pascal ABC. Напишите программу:

Дан двухмерный массив A[1 ... m, 1 ... n]. Написать программу построения одномерного массива B[1 ... m], элементы которого соответственно равны суммам элементов строк.

+1
Ответы (1)
  1. 30 июня, 22:52
    0
    Const

    m=100;

    n=100;

    var

    a:array[1 ... m, 1 ... n]of integer;

    b:array[1 ... m]of integer;

    i, j:integer;

    begin

    for i:=1 to m do

    for j:=1 to n do

    a[i, j]:=random (200) - 100;

    for i:=1 to m do

    b[i]:=0;

    for i:=1 to m do

    for j:=1 to n do

    b[i]:=b[i]+a[i, j];

    for i:=1 to m do

    write (b[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Язык Pascal ABC. Напишите программу: Дан двухмерный массив A[1 ... m, 1 ... n]. Написать программу построения одномерного массива B[1 ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы