Задать вопрос
23 декабря, 18:58

Напишите программу на Паскале. Дан целочисленный квадратный массив 10x10. Найти сумму максимальных элементов из каждой строки. Предпологается, что в каждой строке такой элемент единственный

+3
Ответы (1)
  1. 23 декабря, 21:05
    0
    var

    a : array [1 ... 10] of longint;

    i, j, max, ans : longint;

    begin

    for i:=1 to 10 do

    begin

    max:=-maxlongint;

    for j:=1 to 10 do

    begin

    read (a[i]) ;

    if a[i]>max then max:=a[i];

    end;

    ans:=ans+max;

    writeln;

    end;

    writeln (ans) ;

    end.

    И этот массив не квадратный. Такие массивы называют двумерными массивами.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на Паскале. Дан целочисленный квадратный массив 10x10. Найти сумму максимальных элементов из каждой строки. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы