Задать вопрос
18 июля, 05:42

Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в другой файл. Учтите, что таких чисел может вообще не быть.

(Язык программирования Паскаль)

+3
Ответы (1)
  1. 18 июля, 07:31
    0
    {Напишите программу, которая находит минимальное и максимальное

    среди чётных положительных чисел, записанных в файле,

    и выводит результат в другой файл.}

    var f:text;

    min, max, a : integer;

    find:boolean; { есть/нет числа удовлетворяющие условию }

    begin

    assign (f,'dan. txt') ; reset (f) ;

    min:=0; max:=0;

    find:=false;

    while not eof (f) do

    begin

    read (f, a) ;

    if not find and (a>0) and (a mod 2=0) then

    begin

    min:=a; find:=true;

    end

    else

    if find and (a>0) and (a mod 2=0) and (min>a) then

    min:=a;

    if (a>0) and (a mod 2=0) and (max
    max:=a;

    end;

    close (f) ;

    assign (f,'res. txt') ;

    rewrite (f) ;

    if max=0 then writeln (f,'чётных положительных чисел нет')

    else

    writeln (f,'min среди чётных положительных чисел = ', min, chr (13),

    'max среди чётных положительных чисел нет', max) ;

    close (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать программу, которая находит максимальное нечетное число среди чисел, записанных в файле, и выводит результат в другой файл. подскажите как найти это число хотя бы
Ответы (1)
Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел, уже записанных в готовом текстовом файле, и выводит результат в другой файл.
Ответы (1)
Напишите программу, которая находит максимальное всех арифметических чисел, записанных в файле в столбик, и выводит результат в другой файл
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.
Ответы (1)