Задать вопрос
2 августа, 12:40

Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу

+1
Ответы (1)
  1. 2 августа, 13:57
    0
    Const

    handsfree = false;

    nmax = 4;

    random_min = - 50;

    random_max = 50;

    var

    a: array[1 ... nmax] of integer;

    i, n, j: integer;

    sum, product, harmonic: real;

    k: integer;

    begin

    {ввод массива}

    n : = nmax;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (random_max - random_min) + random_min;

    write (a[i], ' ') ;

    end

    else

    readln (a[i]) ;

    end;

    writeln () ;

    {подсчет элементов}

    k : = 0;

    for i : = 1 to n do

    if a[i] mod 2 = 0 then

    k : = k + 1;

    writeln ('quantity = ', k) ;

    {подсчет суммы и произведения и агригатов}

    sum : = 0;

    for i : = 1 to n do

    sum : = sum + a[i];

    writeln ('sum = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы