Задать вопрос
3 июня, 15:56

Написать программу для нахождения суммы 1/1+1/2+1/3 + ... 1/n

+4
Ответы (2)
  1. 3 июня, 16:31
    0
    Var i, n: integer;

    S: real;

    Begin

    Readln (n) ;

    S:=0;

    For i:=1 to n do S:=S+1/i;

    Write (' Сумма равна: ', S) ;

    Readln;

    End.
  2. 3 июня, 17:01
    0
    Var c, c1:real;

    i, b, a, b1, n:integer;

    begin

    readln (n) ;

    b:=1; a:=1; c:=0;

    for i:=1 to n do

    begin

    b1:=b+1;

    c:=a/b1;

    end;

    c1:=c + (1/1) ;

    write (c1:0:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для нахождения суммы 1/1+1/2+1/3 + ... 1/n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы