Задать вопрос
27 апреля, 14:02

Задача в pascal:

Даны n чисел из отрезка (-20; 20). Найти максимальное четное и максимальное нечетное числа

+2
Ответы (1)
  1. 27 апреля, 15:30
    0
    Var

    n, i, mn, mx, a:integer;

    begin

    writeln ('Vvedite n:') ;

    readln (n) ;

    writeln ('Vvedite chisla iz otrezka (-20; 20) : ') ;

    mn:=0;

    mx:=0;

    for i:=1 to n do

    begin

    readln (a) ;

    if (a mod 2) = 0 then

    if mx
    if (a mod 2) 0 then

    if mn

    end;

    writeln ('Maximalnoe chetnoe = ', mx) ;

    writeln ('Maximalnoe nechetnoe = ', mn) ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача в pascal: Даны n чисел из отрезка (-20; 20). Найти максимальное четное и максимальное нечетное числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
даны числа 400, 121, 93,80, 4. прочитай правила и запиши на каждом листке. если число нечётное то его записывают на листке с подписью дик если число нечётное и трехзначное то его записывают на листке с подписью ник если число четное или трехзначное
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Напишите программу в PaskalABC, которая в последовательности натуральных чисел определяет максимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)