Задать вопрос
4 января, 12:21

Найдите суммы положительных и отрицательных чисел из заданных n чисел. Определите наибольшее из сумм по абсолютной величине

+3
Ответы (1)
  1. 4 января, 14:00
    0
    Program_z1;

    var n, So, Sp, i:integer;

    begin

    read (n) ;

    So:=0;

    Sp:=0;

    for i:=1 to n do begin

    if i>0

    then Sp:=Sp+i

    else So:=So+i;

    end;

    if So>Sp

    then write ('So', So)

    else write ('Sp', Sp) ;

    readln; readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найдите суммы положительных и отрицательных чисел из заданных n чисел. Определите наибольшее из сумм по абсолютной величине ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы