Задать вопрос
21 июля, 18:13

Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.

+5
Ответы (1)
  1. 21 июля, 19:34
    0
    Program Pr1;

    uses crt;

    var fl1, fl2:text;

    n, tmp:string;

    Begin

    clrscr;

    assign (fl1,'input. txt') ;

    assign (fl2,'output. txt') ;

    reset (fl1) ;

    readln (fl1, n) ;

    close (fl1) ;

    tmp:=copy (n, length (n),1) ;

    n:=tmp+n;

    rewrite (fl2) ;

    writeln (fl2, n) ;

    close (fl2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы