Задать вопрос
25 сентября, 13:44

Купец привез на рынок рулон сукна длиной N вершков, но для уплаты пошлины ему нужно указать длину сукна в саженях, аршинах, пядях и вершках. Помогите ему - переведите длину сукна, записанного в вершках в сажени, аршины, пяди и вершки.

Программа получает на вход одно натуральное число N, не превосходящее 2109, - длину сукна в вершках.

Программа должна вывести 4 целых неотрицательных числа S, A, P, V - количество саженей, аршин, пядей и вершков, в сумме дающих ровно N вершков, при этом значение A должно быть меньше 3 (т. к. 3 аршина дают одну сажень), значение P должно быть меньше 4 (четыре пяди дают один аршин), значение V должно быть меньше 4 (четыре вершка дают одну пядь).

+3
Ответы (1)
  1. 25 сентября, 16:13
    0
    Var n, s, a, p, v:integer;

    begin

    write ('N = ') ; readln (n) ;

    s:=n div (3*4*4) ;

    a: = (n mod (3*4*4)) div (4*4) ;

    p: = (n mod (4*4)) div 4;

    v:=n mod 4;

    writeln ('s = ', s,' a = ', a,' p = ', p,' v = ', v) ;

    end.

    Пример:

    N = 2061

    s = 42 a = 2 p = 3 v = 1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Купец привез на рынок рулон сукна длиной N вершков, но для уплаты пошлины ему нужно указать длину сукна в саженях, аршинах, пядях и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы