Задать вопрос
11 мая, 04:02

Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей. Если да програма должна вывести true, если нет - false.

+2
Ответы (1)
  1. 11 мая, 05:08
    0
    Var a, b:integer; l:boolean;

    begin

    write ('a = ') ;

    readln (a) ;

    l:=true;

    while (a0) do

    begin

    b:=a;

    write ('a = ') ;

    readln (a) ;

    if (a0) and (a<=b) then l:=false;

    end;

    writeln (l) ;

    end.

    Пример 1:

    a = 3

    a = 6

    a = 9

    a = 4

    a = 0

    False

    Пример 2:

    a = 3

    a = 6

    a = 7

    a = 0

    True
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы