Задать вопрос
13 февраля, 10:45

Напишите программу на языке паскаль. богатый и бедный заключили спор. богатый отдает каждый день 100 в течение месяца. бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца, кто выграет спор

+1
Ответы (1)
  1. 13 февраля, 11:24
    0
    Var m1, m2, st, i:integer;

    begin

    m1:=0; m2:=0;

    st:=1;

    for i:=1 to 30 do

    begin

    m1:=m1+100;

    m2:=m2+st;

    st:=st*2;

    end;

    writeln ('Богатый: ', m1,' бедный: ', m2) ;

    if m1
    then writeln ('Выиграл богатый') else writeln ('Выиграл бедный') ;

    end.

    Результат:

    Богатый: 3000 бедный: 1073741823

    Выиграл богатый
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке паскаль. богатый и бедный заключили спор. богатый отдает каждый день 100 в течение месяца. бедный отдает в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы