Задать вопрос
4 сентября, 13:57

Составить программу, которая формирует массив из 5 случайных чисел от - 10 до 15.

а) найти элементы равные 1.

б) найти индекс нечетных элементов.

в) Найти количество положительных элементов.

+4
Ответы (1)
  1. 4 сентября, 16:48
    0
    Const n=5;

    var a : array[1 ... n] of integer;

    k, i : integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (26) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('элементы равные 1 имеют номера:') ;

    for i:=1 to n do if a[i]=1 then write (i:3) ;

    writeln;

    writeln ('индексы нечетных элементов:') ;

    for i:=1 to n do if a[i] mod 20 then write (i:3) ;

    writeln;

    k:=0;

    for i:=1 to n do if a[i]>0 then k:=k+1;

    writeln ('количество положительных элементов=', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая формирует массив из 5 случайных чисел от - 10 до 15. а) найти элементы равные 1. б) найти индекс нечетных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы