Задать вопрос
15 ноября, 03:13

напишите программу вычисляющую значение функции y=1 при x<0, y=0 при x=0, y=-1 при x<0

+3
Ответы (1)
  1. 15 ноября, 06:46
    0
    В условии опечатка: два раза написано x < 0.

    1) Если функция имеет вид y = 1 при x > 0, 0 при x = 0, - 1 при x < 0:

    var

    x: real;

    y: integer;

    begin

    readln (x) ;

    if x > 0 then

    y : = 1

    else if x = 0 then

    y : = 0

    else

    y : = - 1;

    writeln (y)

    end.

    2) Если функция имеет вид y = 1 при x 0, надо просто поменять местами 1 и - 1 в решении выше.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «напишите программу вычисляющую значение функции y=1 при x ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы