Задать вопрос
21 декабря, 05:20

Напишите программу для решения следующей задачи.

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

+4
Ответы (1)
  1. 21 декабря, 08:20
    0
    Var N, i, k, z:integer;

    s:real;

    begin

    s:=0;

    k:=0;

    repeat

    write ('Введите кол-во дней : ') ;

    readln (N) ;

    until (N>=1) and (N<=31) ; {проверка на верное количество дней}

    for i:=1 to N do

    begin

    write ('Введите значение температуры в ', i,' день : ') ;

    readln (z) ;

    s:=s+z;

    if z>0 then k:=k+1;

    end;

    s:=s/N;

    writeln ('Средняя температура = ', s) ;

    if k>=5 then writeln ('YES') else writeln ('NO') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы