Задать вопрос
2 апреля, 18:28

Написать на Паскале

Остаток

Входные данные

Вводятся 4 числа: a, b, c и d.

Выходные данные

Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.

Примеры

входные данные

2

5

0

2

выходные данные

2 4

входные данные

2

7

9

14

+4
Ответы (1)
  1. 2 апреля, 21:05
    0
    Var

    a, b, c, d, i:integer;

    begin

    writeln ('Ввежите значения для a, b, c, d,') ;

    readln (a, b, c, d) ;

    writeln ('Результат') ;

    for i:=a to b do

    if (i mod d) = c then write (i,' ') ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать на Паскале Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы