Задать вопрос
13 марта, 00:43

Составьте программу, увеличивающую четные элементы линейного массива A[1 ... N] на 1

+1
Ответы (1)
  1. 13 марта, 00:52
    0
    Var

    i, n:integer;

    a:array [1 ... 1000] of integer;

    Begin

    Read (n) ;

    For i:=1 to n do

    Read (a[i]) ; / / вводим элементы массива

    For i:=1 to n do begin

    If a[i] mod 2 = 0 then inc (a[i]) ; / / прибавляем 1 к четным элементам

    Write (a[i], ' ') ;

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, увеличивающую четные элементы линейного массива A[1 ... N] на 1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы