Задать вопрос
12 ноября, 04:21

Составить программу которая вводит х и у с клавиатуры вычисляет и выводит на экран значение z = 9x^4 - корень из x+|y| поделить на (y+7) в фарматном виде с двумя знаками после точки

+4
Ответы (1)
  1. 12 ноября, 04:32
    0
    Могу предложить на Паскале:

    uses Crt;

    var x, y, z: real;

    begin

    ClrScr;

    Write ('x = ') ; ReadLn (x) ;

    Write ('y = ') ; ReadLn (y) ;

    if (y-7) and (x+abs (y) >=0)

    then

    begin

    z:=9*sqr (sqr (x)) - sqrt (x+abs (y)) / (y+7) ;

    WriteLn ('z = ', z:4:2) ;

    end

    else Writeln ('None!') ;

    ReadLn;

    end.

    Здесь важно учесть, что Y не должен равняться (-7), поскольку на 0 делить нельзя, и X должен быть больше или равен модулю Y, поскольку нельзя извлекать корень из отрицательного числа.

    PS: Если надо решение на Си++, то это сделать просто, основываясь на приведенной выше программе ...
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая вводит х и у с клавиатуры вычисляет и выводит на экран значение z = 9x^4 - корень из x+|y| поделить на (y+7) в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы