Задать вопрос
1 сентября, 21:16

Составить программу для вычисления значений переменной y при заданном значении n. (использовать три различных оператора цикла)

y=

+5
Ответы (1)
  1. 1 сентября, 22:17
    0
    Var

    y:real;

    n, i:integer;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    {Цикл с параметром:}

    y:=0;

    For n: = 1 to n do

    y:=y + (1/n) ;

    WriteLn ('y = ', y) ;

    {Цикл с постусловием:}

    y:=0;

    i:=1;

    Repeat

    y:=y + (1/i) ;

    i:=i+1

    Until i>n;

    WriteLn ('y = ', y) ;

    {Цикс с предусловием:}

    y:=0;

    i:=1;

    While i<=n do

    Begin

    y:=y + (1/i) ;

    i:=i+1

    End;

    WriteLn ('y = ', y)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для вычисления значений переменной y при заданном значении n. (использовать три различных оператора цикла) y= ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы