Задать вопрос
26 марта, 07:43

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]

Задана продолжительность некоторого события в секундах целым числом. Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.

Входные данные:

Во входном потоке задано единственное натуральное число T (T < 10000000)

Выходные данные:

Вывести три натуральных числа через пробел: часов, минут, секунд

Пример входного файла (input. txt) :

3666

+2
Ответы (1)
  1. 26 марта, 09:07
    0
    Var

    f: Text;

    T: longint;

    h, m, s, err: integer;

    c: string;

    begin

    Assign (f, 'input. txt') ;

    Reset (f) ;

    Readln (f, c) ;

    Val (c, T, err) ;

    Close (f) ;

    h : = T div 3600;

    T : = T mod 3600;

    m : = T div 60;

    s : = T mod 60;

    writeln (h, ' ', m, ' ', s)

    end.

    Тестовое решение:

    1 1 6
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%] Задана продолжительность некоторого события в секундах целым числом. Считая, что ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы