Задать вопрос
20 июля, 00:06

Дан текст, содержащий не более 10 слов, из строчных русских букв, между соседними словами - запятая, за последним словом - точка. Составить программу, в которой нужно напечатать в алфавитном порядке все гласные буквы, которые входят хотя бы в одно слово более двух раз.

написать на паскале и функций не нужно

+2
Ответы (1)
  1. 20 июля, 01:17
    0
    Const rchars='аеиоуыэюя'; var s: string; mas: array[1 ... length (rchars) ] of integer; k, i: integer;

    begin s:='которой, нужно, напечатать, алфавитном, порядке, все, гласные, буквы, которые.'; {readln (s) ; } {инициализация массива счётчика гласных} for k:=1 to length (rchars) do mas[k]:=0; i:=1; while i<=length (s) do begin {проверка на соответствие буквы гласной, согласно списку гласных} for k:=1 to length (rchars) do if (rchars[k]=s[i]) and (mas[k]-1) then mas[k]:=mas[k]+1; if (s[i]=',') or (s[i]='.') then begin

    {проверить повторение гласных на два и более раз и проинициализировать массив счётчик} for k:=1 to length (rchars) do if (mas[k]<=2) and (mas[k]-1) then mas[k]:=0 else mas[k]:=-1; end; Inc (i) ; end;

    {Вывод повторяющихся гласных}

    s:=''; for k:=1 to length (rchars) do if mas[k]=-1 then s:=s+rchars[k];

    writeln (s) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан текст, содержащий не более 10 слов, из строчных русских букв, между соседними словами - запятая, за последним словом - точка. Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы