Задать вопрос
28 мая, 10:55

Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа

+5
Ответы (1)
  1. 28 мая, 13:37
    0
    program yourname;

    var a, b, c, d:integer;

    begin

    writeln ('Введите ваше число!') ;

    writeln ('В каждую ячейку можно вписать только однозначное число.') ;

    writeln ('Пример: Число 2341 вводится так: 2 3 4 1.') ;

    readln (a, b, c, d) ;

    writeln ('Ваше число: ', a, b, c, d) ;

    writeln ('Произведение цифр вашего числа: ', a*b*c*d) ;

    writeln ('Сумма цифр вашего числа: ', a+b+c+d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы