Задать вопрос
13 сентября, 15:02

1) Требуется создать двумерный массив целых чисел размером MxN, где M и N вводятся пользователем, но не превышают 15. Заполнить массив числами равными сумме индексов элемента (например элемент[3,4] : = 7). Полученные значения заносить во множество. Вывести образованный массив и все элементы сформированного множества.

+2
Ответы (1)
  1. 13 сентября, 15:33
    0
    Насколько я понял, множество - это просто все эти числа, только без повторений.

    Заведем массив boolen, где будем отмечать, есть ли данное число во множестве.

    var

    a : array [1 ... 15, 1 ... 15] of integer;

    b : array [1 ... 30] of boolean;

    i, j, n, m : integer;

    begin

    read (n, m) ;

    for i : = 1 to 30 do b[i] : = false; / / Зануление начальных значений

    for i : = 1 to n do

    for j : = 1 to m do

    a[i, j] : = i + j; / / Заполнение массива

    for i : = 1 to n do

    for j : = 1 to m do

    b[a[i, j]] : = true; / / Формирование множества

    for i : = 1 to n do

    begin

    for j : = 1 to m do

    write (a[i, j], ' ') ;

    writeln;

    end;

    for i : = 2 to 30 do

    if b[i] then write (i, ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Требуется создать двумерный массив целых чисел размером MxN, где M и N вводятся пользователем, но не превышают 15. Заполнить массив ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите написать программу на паскале. Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте программу определения индексов минимального элемента этого массива. Полученный результат вывести на экран.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Пусть есть высказывание А есть: "Множество А есть подмножество множества В ", высказывание В есть: "Все элементы множества А являются элементами множества В".
Ответы (1)