Задать вопрос
29 ноября, 15:49

1. Найти двухзначные числа, которые делятся на сумму своих цифр

2. Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.

+5
Ответы (1)
  1. 29 ноября, 16:09
    0
    Var

    i, m, sum:Integer;

    Begin

    for i:=10 to 99 do

    begin

    m:=i mod 10;

    n:=i div 10;

    sum:=m+n;

    if (i mod sum = 0) then Writeln (i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Найти двухзначные числа, которые делятся на сумму своих цифр 2. Составьте программу вывода количества трёхзначных чисел, у которых цифры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы