Задать вопрос
23 мая, 17:32

С клавиатуры вводится натуральное число. Определите сколько в его записи нечетных чисел

+2
Ответы (1)
  1. 23 мая, 19:58
    0
    Var n: longint;

    k: integer;

    begin

    k:=0;

    write ('Введите число: ') ;

    readln (n) ;

    while n>0 do

    begin

    if n mod 10 mod 20 then

    k:=k+1;

    n:=n div 10;

    end;

    writeln ('В числе ', k,' нечетных цифр') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводится натуральное число. Определите сколько в его записи нечетных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы