Задать вопрос
25 сентября, 00:26

Помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление. Дан номер действия n и вещественные числа a, b (b0). Выполнить над числами указанное действие и вывести результат. Например, n=2, а=0,40, в=1,00. Результат: а-в=-0,60. Единицы длины пронумерованы так: 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр. Дан номер единицы длины и длина отрезка в этих единицах (вещественное число). Найти длину отрезка в метрах.

+1
Ответы (2)
  1. 25 сентября, 00:51
    0
    var

    d:integer;

    a, b:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    write ('Введите номер операции ') ; readln (d) ;

    case d of

    1: writeln (a, ' + ', b, ' = ', a + b) ;

    2: writeln (a, ' - ', b, ' = ', a - b) ;

    3: writeln (a, ' * ', b, ' = ', a * b) ;

    4: begin

    if b 0 then

    writeln (a, ' / ', b, ' = ', a / b)

    else

    writeln ('делить на 0 нельзя') ;

    end;

    else

    writeln ('Неизвестная операция') ;

    end;

    end.

    //вторая программа

    var

    d:integer;

    a:real;

    begin

    write ('Длина отрезка = ') ; readln (a) ;

    write ('Введите код единицы измерения ') ; readln (d) ;

    case d of

    1: writeln ('Длина отрезка ', a / 10, ' метр (а, ов) ') ;

    2: writeln ('Длина отрезка ', a * 1000, ' метр (а, ов) ') ;

    3: writeln ('Длина отрезка ', a, ' метр (а, ов) ') ;

    4: writeln ('Длина отрезка ', a / 1000, ' метр (а, ов) ') ;

    5: writeln ('Длина отрезка ', a / 100, ' метр (а, ов) ') ;

    else

    writeln ('Неизвестная единица длины') ;

    end;

    end.
  2. 25 сентября, 01:55
    0
    { 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр.}

    var

    units: integer;

    value, factor: real;

    begin

    write ('Введите значение - ') ; readln (value) ;

    write ('Введите единицу измерения - ') ; readln (units) ;

    case units of

    1: factor : = 0.1;

    2: factor : = 1000;

    3: factor : = 1;

    4: factor : = 0.001;

    5: factor : = 0.01;

    else

    factor : = 1;

    end;

    writeln (value * factor, ' м') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 - сложение, 2 - вычитание, 3 - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
ЯП Java (Оператор варианта) Арифметические действия над числами пронумерованы следующим образом: 1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление. Дан номер действия N (целое число в диапазоне 1-4) и вещественные числа A и B (В не равно 0).
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Написать программу которая бы по введеному номеру единицы измерения (-дециметр метр километр, миллиметр) выдавала бы соответствующие значения отрезка в метрах
Ответы (1)
Даны два действительных положительных числа x и y. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление).
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)