Задать вопрос
22 июня, 10:34

даны 10 произвольных действительных числа (вводятся с клавиатуры). Подсчитать количество отрицательных чисел помогите составить программу

+2
Ответы (2)
  1. 22 июня, 14:04
    0
    Program Zorkini;

    uses crt;

    const n=10;

    var

    Z: real;

    i, k: integer;

    begin

    k:=0;

    for i:=1 to n do

    begin

    write ('Введите ', i,'-e число ') ;

    readln (z) ;

    if z<0 then k:=k+1;

    end;

    writeln ('Количество отрицательных чисел ', k) ;

    end.
  2. 22 июня, 14:06
    0
    var a, s, i:integer;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    write ('Число: ') ; readln (a) ;

    if a<0 then s:=s+1;

    end;

    writeln ('Кол-во отрицательных чисел: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «даны 10 произвольных действительных числа (вводятся с клавиатуры). Подсчитать количество отрицательных чисел помогите составить программу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы