Задать вопрос
5 декабря, 04:06

Напишите программу для подсчета суммы первых n натуральных чисел. Число n вводится с клавиатуры

+1
Ответы (1)
  1. 5 декабря, 05:41
    0
    Var i, n, s:integer;

    a:array[1 ... 1000] of integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do s:=s+a[i];

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для подсчета суммы первых n натуральных чисел. Число n вводится с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
С клавиатуры вводится строка. С новой строки вводится буква. Составьте программу подсчета количества заданных букв в заданной строке. Определить, является ли длина введенного слова числом, кратным трем.
Ответы (1)