Задать вопрос
26 февраля, 01:03

написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами. Строка S не пустая и содержит не более 200 символов. Строка S состоит только из цифр.

+1
Ответы (1)
  1. 26 февраля, 01:14
    0
    S, a, d:string;

    i, n, j, b:integer;

    c:array[1 ... 200] of integer;

    begin

    readln (s) ;

    readln (n) ;

    a:=copy (s, 1, n) ;

    for i:=1 to n do

    val (a[i], c[i]) ;

    for i:=1 to n do

    for j:=1 to n do

    if c[i]
    b:=c[i]; c[i]:=c[j]; c[j]:=b; end;

    for i:=1 to n do

    str (c[i], d[i]) ;

    s:=d;

    writeln (s) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы