Задать вопрос
5 февраля, 19:32

Требовалось

написать программу, которая вводит с клавиатуры координаты точки на плоскости

(x, y - действительные числа) и определяет принадлежность точки заштрихованной

области, включая ее границы. Программист торопился и написал программу

неправильно. Вот она:

var x, y: real;

begin

readln (x, y) ;

if y>=x then

if y>=0 then

if y<=2-x*x then

write ('принадлежит')

else

write ('не принадлежит')

end

укажите, как нужно доработать программу, чтобы не было случаев неправильной работы. Это можно сделать несколькими способами. Можно указать любой способ доработки исправленной программы

+4
Ответы (1)
  1. 5 февраля, 21:43
    0
    За место двух последних if напиши elif
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y - действительные числа) и определяет ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы